PrePurchasing Email Notifications
Incident Report for UC Davis: CA&ES Dean's Office
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 15, 2017 - 12:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Aug 02, 2017 - 12:58 PDT
Investigating
We have an issue where emails are being bounced so some users are not getting notifications.
Posted 3 months ago. Aug 02, 2017 - 11:29 PDT