PrePurchasing
Incident Report for UC Davis: CA&ES Dean's Office
Resolved
This incident has been resolved.
Posted Apr 09, 2018 - 08:47 PDT
Identified
Our Cert expired over the weekend, it should be fixed today (Monday).
Posted Apr 09, 2018 - 07:04 PDT