An update didn't go smoothly
Incident Report for UC Davis: CA&ES Dean's Office
Resolved
This incident has been resolved.
Posted Jan 20, 2021 - 16:18 PST
Monitoring
It should be running correctly, and a little faster now.
Posted Jan 20, 2021 - 15:46 PST
This incident affected: PrePurchasing.